Android Override Error in Eclipse

If we are develop Android Applications on Eclipse and get this error:

Android requires .class compatibility set to 5.0. Please fix project properties.

or
Error on @Override annotations.

This is only valid from Java 6 onward. It’s an error in Java 5.
Use this to fix it:
Make sure that your IDE projects are setup to use a Java 6 JRE, and that the “source compatibility” is set to 1.6 or greater. Open the Window > Preferences dialog, and browse to Java > Compiler. There you can set the “Compiler compliance level” to 1.6.

Remember that Eclipse can override these global settings for a specific project, so check those too.

Iklan
Perihal

Selalu berusaha menjadi lebih baik... I have a BIG DREAM

Tagged with: , ,
Ditulis dalam Android, Java

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout /  Ubah )

Foto Google

You are commenting using your Google account. Logout /  Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout /  Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout /  Ubah )

Connecting to %s

%d blogger menyukai ini: